Commit eb70bb4f authored by Yassine Doghri's avatar Yassine Doghri
Browse files

fix: update purgecss content path for php helper files

- fix overshooting podcast name when too long in podcast sidebar
- update npm packages to latest versions

fixes #59
parent c39efc94
@tailwind base;
/* Start purging... */
@tailwind components;
/* Stop purging. */
/* Start purging... */
@tailwind utilities;
/* Stop purging. */
......@@ -39,14 +39,14 @@ $podcastNavigation = [
<img
src="<?= $podcast->image->thumbnail_url ?>"
alt="<?= $podcast->title ?>"
class="object-cover w-16 h-16 mr-2"
class="object-cover w-16 h-16"
/>
<div class="flex flex-col items-start flex-1">
<span class="font-semibold truncate"><?= $podcast->title ?></span>
<div class="flex flex-col items-start flex-1 w-48 px-2">
<span class="w-40 text-sm font-semibold truncate" title="<?= $podcast->title ?>"><?= $podcast->title ?></span>
<a href="<?= route_to(
'podcast',
$podcast->name
) ?>" class="inline-flex items-center text-sm underline outline-none hover:no-underline focus:shadow-outline"
) ?>" class="inline-flex items-center text-xs underline outline-none hover:no-underline focus:shadow-outline"
data-toggle="tooltip" data-placement="bottom" title="<?= lang(
'PodcastNavigation.go_to_page'
) ?>">@<?= $podcast->name ?>
......
This diff is collapsed.
......@@ -24,7 +24,7 @@
"commit": "git-cz"
},
"dependencies": {
"@amcharts/amcharts4": "^4.9.37",
"@amcharts/amcharts4": "^4.10.7",
"@amcharts/amcharts4-geodata": "^4.1.17",
"@popperjs/core": "^2.5.3",
"choices.js": "^9.0.1",
......@@ -40,7 +40,7 @@
"@babel/preset-typescript": "^7.10.4",
"@commitlint/cli": "^11.0.0",
"@commitlint/config-conventional": "^11.0.0",
"@prettier/plugin-php": "^0.14.3",
"@prettier/plugin-php": "^0.15.0",
"@rollup/plugin-babel": "^5.2.1",
"@rollup/plugin-commonjs": "^15.1.0",
"@rollup/plugin-json": "^4.1.0",
......@@ -49,23 +49,23 @@
"@tailwindcss/custom-forms": "^0.2.1",
"@tailwindcss/typography": "^0.2.0",
"@types/prosemirror-markdown": "^1.0.3",
"@types/prosemirror-view": "^1.15.1",
"@typescript-eslint/eslint-plugin": "^4.3.0",
"@typescript-eslint/parser": "^4.3.0",
"@types/prosemirror-view": "^1.16.0",
"@typescript-eslint/eslint-plugin": "^4.4.1",
"@typescript-eslint/parser": "^4.4.1",
"cross-env": "^7.0.2",
"cssnano": "^4.1.10",
"cz-conventional-changelog": "^3.3.0",
"eslint": "^7.10.0",
"eslint": "^7.11.0",
"eslint-config-prettier": "^6.12.0",
"eslint-plugin-prettier": "^3.1.4",
"husky": "^4.3.0",
"lint-staged": "^10.4.0",
"postcss-cli": "^8.0.0",
"postcss-cli": "^8.1.0",
"postcss-import": "^12.0.1",
"postcss-preset-env": "^6.7.0",
"prettier": "2.1.2",
"prettier-plugin-organize-imports": "^1.1.1",
"rollup": "^2.28.2",
"rollup": "^2.30.0",
"rollup-plugin-multi-input": "^1.1.1",
"rollup-plugin-node-polyfills": "^0.2.1",
"rollup-plugin-postcss": "^3.1.8",
......@@ -73,7 +73,7 @@
"stylelint": "^13.7.2",
"stylelint-config-standard": "^20.0.0",
"svgo": "^1.3.2",
"tailwindcss": "^1.8.10",
"tailwindcss": "^1.9.1",
"typescript": "^4.0.3"
},
"husky": {
......
/* eslint-disable */
module.exports = {
purge: [
"./app/Views/**/*.php",
"./app/Views/**/*.ts",
"/app/Helpers/**/*.php",
],
purge: ["./app/Views/**/*.php", "./app/Views/**/*.ts", "./app/Helpers/*.php"],
theme: {},
variants: {
textDecoration: ["responsive", "hover", "focus", "group-hover"],
......@@ -17,5 +13,7 @@ module.exports = {
future: {
removeDeprecatedGapUtilities: true,
purgeLayersByDefault: true,
defaultLineHeights: true,
standardFontWeights: true,
},
};
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment